VX.STUDIO

v1.4

Copyright 2004, 2006 by Kai Kostack

 

INTRODUCTION

VX.Studio is a voxel landscape generator with multiple functions for fractal map generation, surface deforming, object editing and many more.

It was originally created for the V2 engine to make game maps on the calculator without the use of a PC.

 

This software works with two file formats, VXS files containing whole voxel maps and VXO files voxel objects.

A VXS map has always two files, in one is stored the height data and in the other one the texture map.

 

The keys you need over the different editor screens should all be shown on the menus, some of them will work on the most locations like the zoom keys.

 

MEMORY

As you will see VX.Studio is a very memory consuming software,
it needs around 160 kbytes of free RAM and - in case you haven't already a map saved on your calc (MAPH.VXS & MAPT.VXS) - about 100 kbyte of Archive Memory. 

Your should archive any file on the calc to get the needed RAM free.
I know that some installed flash software uses RAM too,
also if they seem not running. You can also try to remove memory
resident programs temporarely. OS-extensions like PreOS aren't needed at all, you can remove them. Of course, these are only tips for the worst case. But let me say VX.Studio is Nostub, so it will run on a blank AMS too.

Be careful on having error messages like "to less RAM" or "to less AM", they can cause your calc to crash, because this errors are happening mostly during memory allocation or loading processes. If one of those errors occure anyway, VX.Studio will try to recover your systems memory but sometimes it won't work.
The "garbage collect" display which appears sometimes if you have low AM during saving is quite normal, you need only to press [Enter].

 

REFERENCE

1.

 

1.1.

1.2.

1.3.

 

2.

 

2.1.

 

2.1.1.

2.1.2.

2.1.3.

 

2.2.

2.3.

2.4.

 

3.

 

3.1.

 

3.1.1.

3.1.2.

3.1.3.

 

3.2.

 

3.2.1.

3.2.2.

3.2.3.

3.2.4.

 

3.3.

 

3.3.1.

3.3.2.

 

3.4.

 

3.4.1.

3.4.2.

3.4.3.

 

3.4.3.1.

3.4.3.2.

 

3.4.3.2.1.

3.4.3.2.2.

3.4.3.2.3.

3.4.3.2.3.

 

3.4.3.3.

3.4.3.4.

 

3.4.4.

 

3.4.4.1.

3.4.4.2.

3.4.4.3.

3.4.4.4.

 

4.

 

4.1.

4.2.

+-+ File

| |

| +-- Save

| +-- Save & exit

| +-- Exit

|

+-+ New map

| |

| +-+ Random map

| | |

| | +-- Seed

| | +-- Roughness

| | +-- Do it!

| |

| +-- Random texture

| +-- Smoother height map

| +-- Smoother texture map

|

+-+ Editor

| |

| +-+ Texture map

| | |

| | +-- Pencil

| | +-- Airbrush

| | +-- Undo

| |

| +-+ Height map

| | |

| | +-- Push

| | +-- Pull

| | +-- Flatten square

| | +-- Undo

| |

| +-+ Both

| | |

| | +-- Lake

| | +-- Undo

| |

| +-+ Object

|   |

|   +-- New

|   +-- Load

|   +-+ Edit

|   | |

|   | +-- Save

|   | +-+ Preview & rotate

|   | | |

|   | | +-- Rotate 1x

|   | | +-- Rotate 2x

|   | | +-- Rotate 3x

|   | | +-- Double size

|   | |

|   | +-- Point

|   | +-- Square

|   |

|   +-+ Place

|     |

|     +-- Solid

|     +-- Solid boolean

|     +-- Flexible

|     +-- Undo

|

+-+ View

  |

  +-- Shade

  +-- Isometric

 

1.

File ->

1.1.

File -> Save

Saves the map files. 

Caution:

Make sure you have enough archive memory free, the map files can reach a file size of about 100k.

 

You need to confirm "garbage collection" dialog otherwise your map will get lost.

 

1.2.

File -> Save & exit

Saves the map files and returns to OS. 

 

1.3.

File -> Exit

Returns to OS. 

2.

New map ->

2.1.

New map -> Random map ->

2.1.1.

New map -> Random map -> Seed

Enter a seed number for random map generation here. If you press only ENTER a random seed number will be set.

 

The seed number is the base for the generated map. With it you are able to reproduce exactly the same random map.

2.1.2.

New map -> Random map -> Roughness

Enter a roughness value for random map generation here. The smaller the value is the smoother is the map. If you only press ENTER the default value of 5 will be set. 

2.1.3.

New map -> Random map -> Do it!

Executes the map generation process.

2.2.

New map -> Random texture

This option creates a random texture map without changing the height map. This will happen automaticly if you are creating a completely new random map. 

2.3.

New map -> Smoother height map

Applies a filter for smoothing on the height map.

Caution:

The result is hard to see in the editor but it will make everything smoother also edges from buildings or other structures, you should only use it on completely new maps.

2.4.

New map -> Smoother texture map

Applies a filter for smoothing on the texture map.

Caution:

It could distort the textures of buildings or other structures, you should only use it on completely new maps.

3.1.

Editor -> Texture map ->

3.1.1.

Editor -> Texture map -> Pencil

Draws a single point on the texture map with the current color.

3.1.2.

Editor -> Texture map -> Airbrush

Scatters multiple points on the texture map with the current color.

3.1.3.

Editor -> Texture map -> Undo

Not a real "undo" this option just reloads the texture map.

3.2.

Editor -> Height map ->

3.2.1.

Editor -> Height map -> Push

Pushes a bump into the terrain.

3.2.2.

Editor -> Height map -> Pull

Pulls a bump out of the terrain.

3.2.3.

Editor -> Height map -> Flatten square

Makes a square of the terrain even.

The edges will be formed like a flat crater.

Height base is the lowest point in the squares terrain area.

Caution:

You have to draw from top left to down right otherwise it won't work.

3.2.4.

Editor -> Height map -> Undo

Not a real "undo" this option just reloads both maps.

3.3.

Editor -> Both ->

3.3.1.

Editor -> Both -> Lake

Generates a real looking water surface on the whole map. The software takes the water height from the current cursor position.

Tip:

You can try and undo until you have what you wanted or, because of you can't see on this screen the height map for setting an exact water depth, you could get to the height map editor, move the cursor to the terrain height position you prefer and come back to this menu without moving the cursor and you have the coordinates for the right water depth.

Caution:

This option can easily destroy your map, if you don't want to lost your terrain then make a map backup!

3.3.2.

Editor -> Both -> Undo

Not a real "undo" this option just reloads both maps.

3.4.

Editor -> Object ->

3.4.1.

Editor -> Object -> New

Erases the object memory and opens the object editor.

3.4.2.

Editor -> Object -> Load

Opens a window were you can choose a VXO file from current directory to load it.  

3.4.3.

Editor -> Object -> Edit ->

3.4.3.1.

Editor -> Object -> Edit -> Save

Saves the object.

3.4.3.2.

Editor -> Object -> Edit -> Preview & rotate ->

3.4.3.2.1.

Editor -> Object -> Edit -> Preview & rotate -> Rotate 1x 

Rotates the object by 90.

3.4.3.2.2.

Editor -> Object -> Edit -> Preview & rotate -> Rotate 2x 

Rotates the object by 180.

3.4.3.2.3.

Editor -> Object -> Edit -> Preview & rotate -> Rotate 3x 

Rotates the object by 270.

3.4.3.2.4.

Editor -> Object -> Edit -> Preview & rotate -> Double size

Displays the center of the object twice the size of the original.

3.4.3.3.

Editor -> Object -> Edit -> Point

Draws or colorizes a single voxel.

New voxels must be created on the left screen. Existing voxels can be colorized on the right screen. If you draw with color 0 then the voxel will be erased.

3.4.3.4.

Editor -> Object -> Edit -> Square

Draws or colorizes a square of voxels.

New voxels must be created on the left screen. Existing voxels can be colorized on the right screen. If you draw with color 0 then the voxel will be erased.

Caution:

You have to draw from top left to down right otherwise it won't work.

3.4.4.

Editor -> Object -> Place ->

3.4.4.1.

Editor -> Object -> Place -> Solid

Places the loaded object without deforming it.

Height base is the lowest point in the objects terrain area.

3.4.4.2.

Editor -> Object -> Place -> Solid boolean

Places the loaded object without deforming it.

Each voxel from the object will be ignored which is lower than the terrain voxel on this position.

Height base is the lowest point in the objects terrain area.

3.4.4.3.

Editor -> Object -> Place -> Flexible

Places the loaded object fitted to the terrains surface.

Height base is the lowest point in the objects terrain area.

Tip:

This is a good option if you want to lay roads or paths through the terrain.

3.4.4.4.

Editor -> Object -> Place -> Undo

Removes the placed object.

4.

View ->

4.1.

View -> Shade

Applies a realistic shader on the texture map.

4.2.

View -> Isometric

Applies a realistic shader on the texture map and shows the map in 3D.